Opalstack - Mail server certificates expired – Incident details

Mail server certificates expired

Resolved
Operational
Started over 4 years agoLasted 27 minutes

Affected

Americas Hosting

Email - SMTP

Updates
  • Resolved
    Resolved

    The issue is now resolved. The root cause was an obsolete root certificate on our servers. The certificate has been updated.

  • Investigating
    Investigating

    The SSL certificates used by Opalstack's mail servers are expired. We're working to correct that at this time and should have it resolved shortly.