Opalstack - German SMTP offline – Incident details

German SMTP offline

Resolved
Operational
Started over 4 years agoLasted about 3 hours

Affected

Europe Hosting

Email - SMTP

Updates
  • Resolved
    Resolved

    The certificate has been updated and SMTP is now working normally. We're reviewing and revising our internal procedures to minimize the chance of this happening again in the future.

  • Investigating
    Investigating

    German SMTP was offline due to a problem with the server certificate.