Opalstack - Delays in mail forwarding to Google – Incident details

Delays in mail forwarding to Google

Resolved
Operational
Started 10 months agoLasted about 9 hours

Affected

Americas Hosting

Email - MX

mx2.us.opalstack.com

Europe Hosting

Email - MX

mx2.de.opalstack.com

Updates
  • Investigating
    Investigating

    Google had rate-limited 2 of our forwarding MX servers over the weekend resulting in forwarding delays for some users who forward mail to Gmail.

    We've corrected the cause of the rate limit and expect all pending mail to be delivered over the next several hours.We are currently investigating this incident.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Resolved
    Resolved

    All of the pending forwarded mail has been delivered.