Opalstack - EU mail system blocked by Hotmail – Incident details

EU mail system blocked by Hotmail

Resolved
Operational
Started 10 months agoLasted about 12 hours

Affected

Europe Hosting

Operational from 10:21 PM to 10:30 AM

Email - SMTP

Operational from 10:21 PM to 10:30 AM

smtp2.de.opalstack.com

Operational from 10:21 PM to 10:30 AM

Email - MX

Operational from 10:21 PM to 10:30 AM

mx1.de.opalstack.com

Operational from 10:21 PM to 10:30 AM

mx2.de.opalstack.com

Operational from 10:21 PM to 10:30 AM

Updates
  • Resolved
    Resolved

    All blocks have been lifted.

  • Update
    Update

    mx2.de.opalstack.com was added to the block list as well, we have submitted the delisting request and are awaiting action from Microsoft.

  • Monitoring
    Monitoring

  • Investigating
    Investigating

    Part of our EU mail infrastructure was blocked by Hotmail. The affected servers were:

    • smtp2.de.opalstack.com (outgoing mail)

    • mx1.de.opalstack.com (incoming mail and forwarding)

    We've already dealt with the issue and Microsoft have confirmed that the servers have been unblocked, but it may take a few more hours to take full effect.

    We'll update this post when we've confirmed that mail is no longer being blocked.