Opalstack - German MX servers are on Hotmail block list – Incident details

German MX servers are on Hotmail block list

Resolved
Operational
Started 12 months agoLasted about 20 hours

Affected

Europe Hosting

Email - SMTP

Updates
  • Resolved
    Resolved

    The MX servers have been removed from the block list.

  • Investigating
    Investigating

    mx1.de.opalstack.com and mx2.de.opalstack.com are listed on the Hotmail block list. As a result, mail forwarded to Hotmail domains like hotmail.com and outlook.com is being bounced back to the sender.

    We're working to have the servers removed from the block list and will update this post when that is done.

    In the meantime, customers who have forwarding addresses which forward to Hotmail domains are advised to forward to an alternate address or direct mail to an Opalstack mailbox to ensure that they receive their mail. Instructions for updating email addresses are available in our user guide at: Editing Email Addresses