Opalstack - US SMTP listed on SORBS block list – Incident details
All systems operational
US SMTP listed on SORBS block list
Resolved
Operational
Started about 1 year agoLasted 3 days
Affected
Americas Hosting
Email - SMTP
Updates
Resolved
Resolved
The US SMTP server is no longer listed on the SORBS block list.
Investigating
Investigating
Our US SMTP server is currently listed on the SORBS email block list. We've already gone through the de-listing process and expect the server to be de-listed in 48 hours or less.
We'll update this post when we confirm the server is de-listed.