Opalstack - US SMTP and community forum are offline – Incident details

US SMTP and community forum are offline

Resolved
Operational
Started about 1 year agoLasted 12 minutes

Affected

Americas Hosting

Email - SMTP

Updates
  • Resolved
    Resolved

    The US SMTP server and community forum are back online.

  • Investigating
    Investigating

    At this time our US SMTP server (outgoing mail) and our community forum are offline. We're investigating and will update this post when more information is available.