Opalstack - DE SMTP was blocked by Abusix – Incident details

DE SMTP was blocked by Abusix

Resolved
Operational
Started almost 2 years agoLasted about 5 hours

Affected

Europe Hosting

Email - SMTP

Updates
  • Resolved
    Resolved

    The DE SMTP is no longer blocked.

  • Investigating
    Investigating

    Our DE SMTP server was listed in the Abusix Mail Intelligence block list. We've already initiated the delisting process and expect the issue to be resolved within the next 60 minutes.