Opalstack - US SMTP blacklisted – Incident details

US SMTP blacklisted

Resolved
Operational
Started almost 3 years agoLasted about 3 hours

Affected

Americas Hosting

Email - SMTP

Updates
  • Resolved
    Resolved

    We've identified and shut down several websites with insecure contact forms which were sending spam. The site operators have been notified and the US SMTP is no longer blacklisted.

  • Investigating
    Investigating

    Our US SMTP service is currently blacklisted. We're working with the blacklist operators to identify the cause and will have it corrected as soon as possible.