Opalstack - German SMTP IP range on MS block list – Incident details

German SMTP IP range on MS block list

Resolved
Operational
Started almost 5 years agoLasted 2 days

Affected

Europe Hosting

Email - SMTP

Updates
  • Resolved
    Resolved

    Microsoft is now accepting mail from smtp.de.opalstack.com.

  • Identified
    Identified

    We've identified and corrected the cause of the block, and have passed our findings along to Microsoft with a request to delist the German SMTP address.

    We'll update this post when Microsoft have confirmed that the server is no longer on the block list.

  • Investigating
    Investigating

    We've received some reports that outlook.com and other Microsoft mail services are blocking smtp.de.opalstack.com.

    We're investigating now and will follow up when we have more info.