Opalstack - US IMAP service not responding – Incident details

US IMAP service not responding

Resolved
Operational
Started about 5 years agoLasted about 1 hour

Affected

Americas Hosting

Email - SMTP

Updates
  • Resolved
    Resolved

    The US IMAP server is back online.

  • Update
    Update

    We're rebooting the US IMAP server at this time.

  • Investigating
    Investigating

    The US IMAP service is currently not responding, we're looking into it.